Global Ubuntu mirror issues
OtherUpdates
-
Monitoring • Canonical suffered issues with Ubuntu mirror distribution overnight. While Canonical has marked the issue as "resolved": https://status.canonical.com/ - we're seeing Ubuntu installs that are slow, or fail due to missing apt packages during installation. Temporarily, we've removed the "security" repo from install images due to package mirror issues, meaning that the auto-installs are completing entirely from ISO at the moment. This means packages are out of date when you receive the server, but per the notice you receive when the reinstall completes, you should be updating and securing the server anyway. There is no need to contact us that public Ubuntu package mirrors are slow or down or failing to respond or responding with a 404 for update-to-date package versions. We'll re-enable the "security" repo in the install templates early next week.
-
Resolved • As we no longer seem to need to restart Ubuntu installs many times to get them through repo mirror issues, we're considering this resolved.