Power feed issue in Chicago
Partial OutageUpdates
-
Investigating • We've been alerted to a potential power feed loss of one of the legs in Chicago. We're investigating now and will update this posting as we have more information.
-
Identified • Confirmed that the A power feed seems to be down. We've reached out to other hosts in the Chicago deployment, and they've confirmed they lost their A power feed too. B power remains online, however single PSU servers (Ryzens, E5-1650s, single PSU colocation on the A feed) will be down. We've opened a ticket with the building to inquire about an ETA for restoration, and will post more details here.
-
Identified • We've received the following from the building. We'll post updates as we have them: ==== Please be advised on Wednesday, July 22, 2026, at 10:00am, the 6th floor data center experienced a failure on UPS B. Facility Engineers and electricians are working to determine the source of the outage. Additional updates will follow every two (2) hours for the duration of the event.
-
Identified • Update from the building: Technicians are on site now assessing the situation. No time estimate as of yet.
-
Identified • We're getting up notices for the power feed, however we haven't received an update from the building confirming power stability. We'll post updates here as we have them.
-
Identified • Update from the building: Please be advised our Facility Engineers and electricians continue to investigate the source of the outage. Electricians are working to restore utility power on UPS B.
-
Resolved • We've received the following update from the building. If you continue to experience any issues related to this situation or require additional assistance, please update your existing support ticket: UPS B has been fully restored and power has returned to normal. Our teams have completed the necessary restoration efforts, and normal power operations have resumed. We appreciate your patience and understanding while we worked to resolve the issue.