Billing system update
Partial OutageUpdates
-
Identified • Our billing system vendor has released a critical software update to patch a security vulnerability, and we are updating the software now. https://my.dedicated.com will be down for a few minutes while this is completed. If you have something that you feel constitutes an emergency at this time, please call us at 844-533-1300. We'll update this posting when the upgrade is complete.
-
Resolved • The upgrade is complete and we've clicked around the client area and weren't able to find any issues. If you note anything that seems like it's not working, please don't hesitate to open a ticket.